Issue: ?yum? does not work properly and reports an error on every single run. Full error message:


Reason: You have outdated alt-libxml2 package which actually read more

To protect packages from CloudLinux repositories from being updated from 3rd party repositories like rpmforge, and to prevent such dependencies issues, do the following:

For CloudLinux 6.x


Edit /etc/yum/pluginconf.d/rhnplugin.conf.
Add:


For CloudLinux 7.x


read more

When you see Segmentation Fault in different random places it could be caused by bad/broken libz* and libxml2. It usually happens on DirectAdmin server, when libraries are placed into /usr/local/lib/ directory.

To fix: