Issue: ?yum? does not work properly and reports an error on every single run. Full error message:


Reason: You have outdated alt-libxml2 package which actually read more

Occasionally, the RPM database on a CloudLinux machine can become corrupted. It can happen when an RPM transaction is interrupted at a critical time. Symptoms of this problem include one of the following programs not responding or freezing:

  • up2date
  • The CLN alert notification tool (applet in the Gnome or KDE panel)
  • rhn_check
  • rpm

This problem read more

If you are having issues installing r1soft-cki, and getting error message like this:

Unable to find a valid source directory. Please install the kernel headers for your operating system Do:


If you are running one of the beta kernels, add ?enablerepo=cloudlinux-updates-testing to the end of the yum command, like:
read more

When you see Segmentation Fault in different random places it could be caused by bad/broken libz* and libxml2. It usualy happens on DirectAdmin server, when libraries are placed into /usr/local/lib/ directory. To fix: