mod_hostinglimits: Already inside LVE. POA/HostingNG

If you are using POA/HostingNG and see following errors in logs:

The issue is in how Apache works on POA. To fix the issue on CloudLinux 6 we have to allow setting up LVE by other (not just LVE admin) users:

Starting from kernel 2.6.32-673.8.1.lve1.4.3.1 :

For kernels before 2.6.32-673.8.1.lve1.4.3.1:

Unfortunately lve_setup_enter used for POA(HostingNG) in mod_hostinglimits can not work correctly under CloudLinux 5, it always return EPERM. So it works only on CL6 or Hybrid kernel.

Hybrid kernel install link: http://docs.cloudlinux.com/index.html?hybrid_kernel.html

Leave a Reply

Your email address will not be published. Required fields are marked *